Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
depots [Le 03/09/2018, 17:59]
88.189.253.25 [Proposed]
depots [Le 12/11/2020, 02:06]
andykimpe modification nom des version LTS Actuelle
Ligne 44: Ligne 44:
 Les sections ''​universe''​ et ''​multiverse''​ des dépôts officiels contiennent des paquets maintenus par //la communauté//​. La Fondation Ubuntu ne contrôle pas ces paquets ; ils sont analysés par un comité d'​utilisateurs. La section ''​universe''​ contient uniquement des paquets libres et la section ''​multiverse'',​ des paquets non-libres. Sauf pour une [[:​live_cd#​Session live : qu'​est-ce que c'est ?|session live]], l'​accès à ces deux sections est paramétré par défaut. Les sections ''​universe''​ et ''​multiverse''​ des dépôts officiels contiennent des paquets maintenus par //la communauté//​. La Fondation Ubuntu ne contrôle pas ces paquets ; ils sont analysés par un comité d'​utilisateurs. La section ''​universe''​ contient uniquement des paquets libres et la section ''​multiverse'',​ des paquets non-libres. Sauf pour une [[:​live_cd#​Session live : qu'​est-ce que c'est ?|session live]], l'​accès à ces deux sections est paramétré par défaut.
  
-^ Adresses des dépôts | **[[depots_trusty#​depots_officiels_actives_par_defaut|Ubuntu ​14.04 LTS (Trusty)]]**  | **[[depots_xenial#​depots_officiels_actives_par_defaut|Ubuntu ​16.04 LTS (Xenial)]]** |+^ Adresses des dépôts | **[[depots_bionic#​depots_officiels_actives_par_defaut|Ubuntu ​18.04 LTS (Bionic)]]**  | **[[depots_focal#​depots_officiels_actives_par_defaut|Ubuntu ​20.04 LTS (Focal)]]** |
  
 ==== Backports ==== ==== Backports ====
Ligne 51: Ligne 51:
 Le projet Ubuntu-Backports prend des logiciels inclus dans la version de développement d'​Ubuntu et crée un nouveau paquet ''​.deb''​ compatible avec la version stable actuelle. Ubuntu-Backports est un projet officiel d'​Ubuntu et est géré bénévolement. //Malgré les tests intensifs effectués sur les paquets recréés, il reste tout de même possible qu'ils causent des instabilités sur votre système.// Le projet Ubuntu-Backports prend des logiciels inclus dans la version de développement d'​Ubuntu et crée un nouveau paquet ''​.deb''​ compatible avec la version stable actuelle. Ubuntu-Backports est un projet officiel d'​Ubuntu et est géré bénévolement. //Malgré les tests intensifs effectués sur les paquets recréés, il reste tout de même possible qu'ils causent des instabilités sur votre système.//
  
-^ Adresses des dépôts | **[[depots_trusty#​depots_backports|Ubuntu ​14.04 LTS (Trusty)]]** | **[[depots_xenial#​depots_backports|Ubuntu ​16.04 LTS (Xenial)]]** |+^ Adresses des dépôts | **[[depots_bionic#​depots_backports|Ubuntu ​18.04 LTS (Bionic)]]** | **[[depots_focal#​depots_backports|Ubuntu ​20.04 LTS (Focal)]]** |
  
  
Ligne 59: Ligne 59:
  
 == Installation / mise à jour d'un paquet rétro-porté == == Installation / mise à jour d'un paquet rétro-porté ==
-Si vous savez que vous souhaitez installer/​mettre à jour une application dans sa version rétroportée((par exemple après une vérification avec <​code>​apt-cache policy nom_du_paquet</​code>​)),​ //il faut le préciser explicitement//​. Pour cela, il faut ajouter ''/​trusty-backports''​ à la ligne de [[:​commande_shell|commande]] apt-get (remplacer //trusty// par le nom de votre [[:​versions|version d'​Ubuntu]]). \\ +Si vous savez que vous souhaitez installer/​mettre à jour une application dans sa version rétroportée((par exemple après une vérification avec <​code>​apt-cache policy nom_du_paquet</​code>​)),​ //il faut le préciser explicitement//​. Pour cela, il faut ajouter ''/​bionic-backports''​ à la ligne de [[:​commande_shell|commande]] apt-get (remplacer //bionic// par le nom de votre [[:​versions|version d'​Ubuntu]]). \\ 
-Par exemple, depuis un [[:​terminal]] pour installer [[Amarok]] à partir des Backports d'[[:trusty|Ubuntu ​Trusty 14.04]] :  +Par exemple, depuis un [[:​terminal]] pour installer [[Amarok]] à partir des Backports d'[[:bionic|Ubuntu ​Bionic 18.04]] :  
-<​code>​sudo apt-get install amarok/trusty-backports</​code>​+<​code>​sudo apt-get install amarok/bionic-backports</​code>​
 ou de manière générique :​ ou de manière générique :​
 <​code>​sudo apt-get install amarok/​$(lsb_release -sc)-backports</​code>​ <​code>​sudo apt-get install amarok/​$(lsb_release -sc)-backports</​code>​
Ligne 68: Ligne 68:
 Avec les [[sudo|droits d'​administrateur]];​ Avec les [[sudo|droits d'​administrateur]];​
   - [[:​tutoriel:​comment_modifier_un_fichier|Modifiez le fichier]] suivant (s'il n'​existe pas, il sera créé en même temps) : **/​etc/​apt/​preferences**   - [[:​tutoriel:​comment_modifier_un_fichier|Modifiez le fichier]] suivant (s'il n'​existe pas, il sera créé en même temps) : **/​etc/​apt/​preferences**
-  - Copiez les lignes suivantes ​ (remplacer //trusty// par le nom de votre [[:​versions|version d'​Ubuntu]])<​file>​+  - Copiez les lignes suivantes ​ (remplacer //bionic// par le nom de votre [[:​versions|version d'​Ubuntu]])<​file>​
   Package: *   Package: *
-  Pin: release a=trusty-backports+  Pin: release a=bionic-backports
   Pin-Priority:​ 500</​file>​   Pin-Priority:​ 500</​file>​
  
Ligne 81: Ligne 81:
 ==== Proposed ==== ==== Proposed ====
 Les dépôts "​proposed"​ contiennent des paquets proposés **à fins de tests seulement** ! Ils servent à tester des paquets ou des mises à jour avant qu'ils n'​intègrent définitivement les dépôts principaux. Ils peuvent donc être à l'​origine de plantage et de corruption de système ! //​**N'​ajoutez ces dépôts que si vous savez ce que vous faites !**// \\ Les dépôts "​proposed"​ contiennent des paquets proposés **à fins de tests seulement** ! Ils servent à tester des paquets ou des mises à jour avant qu'ils n'​intègrent définitivement les dépôts principaux. Ils peuvent donc être à l'​origine de plantage et de corruption de système ! //​**N'​ajoutez ces dépôts que si vous savez ce que vous faites !**// \\
-Ces dépôts correspondent à la case à cocher "Mises à jour en préversion (proposed)"​ -> onglet "Mises à jour" de l'​application [[:​software-properties|Logiciels & Mises à jour]] //(Onglet "​Options de développement"​ pour [[:xenial|Ubuntu Xenial]] et ultérieur)//​.+Ces dépôts correspondent à la case à cocher "Mises à jour en préversion (proposed)"​ -> onglet "Mises à jour" de l'​application [[:​software-properties|Logiciels & Mises à jour]] //(Onglet "​Options de développement"​ pour [[:bionic|UbuntuBionic]] et ultérieur)//​.
  
-^Adresse des dépôts | **[[depots_trusty#​depots_proposed|Ubuntu ​14.04 LTS (Trusty)]]** | **[[depots_xenial#​depots_proposed|Ubuntu ​16.04 LTS (Xenial)]]** |+^Adresse des dépôts | **[[depots_bionic#​depots_proposed|Ubuntu ​18.04 LTS (Bionic)]]** | **[[depots_focal#​depots_proposed|Ubuntu ​20.04 LTS (Focal)]]** |
  
 === Rétrograder les paquets provenant des dépôts Proposed === === Rétrograder les paquets provenant des dépôts Proposed ===
  
 Si vous avez effectué une mise à jour de vos paquets vers la version à des fins de test "​proposed"​ et que vous désirez les retrouver dans les versions "de sécurité", ​ Si vous avez effectué une mise à jour de vos paquets vers la version à des fins de test "​proposed"​ et que vous désirez les retrouver dans les versions "de sécurité", ​
-  - vous devez d'​abord vous assurer que vous avez bien décoché la case: "Mises à jour en préversion (proposed)"​ -> onglet "Mises à jour" de l'​application [[:​software-properties|Logiciels & Mises à jour]] //(Onglet "​Options de développement"​ pour [[:xenial|Ubuntu ​Xenial]] et ultérieur)//​. \\ {{:​depots:​done.png?​600|gestionnaire de source : Proposed}}+  - vous devez d'​abord vous assurer que vous avez bien décoché la case: "Mises à jour en préversion (proposed)"​ -> onglet "Mises à jour" de l'​application [[:​software-properties|Logiciels & Mises à jour]] //(Onglet "​Options de développement"​ pour [[:Bionic|Ubuntu ​Bionic]] et ultérieur)//​. \\ {{:​depots:​done.png?​600|gestionnaire de source : Proposed}}
   - Veuillez ensuite [[:​tutoriel/​comment_modifier_un_fichier|créer le fichier]] **99-downgrade-proposed** dans le dossier **/​etc/​apt/​preferences.d/​** via la [[:​commande_shell|commande]] suivante saisie dans un [[:​terminal]] :<​code>​sudo touch /​etc/​apt/​preferences.d/​99-downgrade-proposed</​code>​   - Veuillez ensuite [[:​tutoriel/​comment_modifier_un_fichier|créer le fichier]] **99-downgrade-proposed** dans le dossier **/​etc/​apt/​preferences.d/​** via la [[:​commande_shell|commande]] suivante saisie dans un [[:​terminal]] :<​code>​sudo touch /​etc/​apt/​preferences.d/​99-downgrade-proposed</​code>​
   - Ouvrez ensuite le fichier **99-downgrade-proposed** via votre éditeur de texte favoris, nous utiliserons [[:|nano]] dans notre exemple, veuillez donc [[:​tutoriel/​comment_modifier_un_fichier|éditer le fichier]], via la [[:​commande_shell|commande]] suivante :<​code>​sudo nano /​etc/​apt/​preferences.d/​99-downgrade-proposed</​code>​Avec le contenu suivant :<​file>​   - Ouvrez ensuite le fichier **99-downgrade-proposed** via votre éditeur de texte favoris, nous utiliserons [[:|nano]] dans notre exemple, veuillez donc [[:​tutoriel/​comment_modifier_un_fichier|éditer le fichier]], via la [[:​commande_shell|commande]] suivante :<​code>​sudo nano /​etc/​apt/​preferences.d/​99-downgrade-proposed</​code>​Avec le contenu suivant :<​file>​
Ligne 118: Ligne 118:
  
 Package: * Package: *
-Pin: release a=nom de votre version d'​Ubuntu((Pour connaître le nom de votre version d'​Ubuntu (trustyxenial ​ou autre), veuillez ouvrir un terminal, et y **copier-coller** cette commande <​code>​lsb_release -sc</​code>​))+Pin: release a=nom de votre version d'​Ubuntu((Pour connaître le nom de votre version d'​Ubuntu (bionicfocal ou autre), veuillez ouvrir un terminal, et y **copier-coller** cette commande <​code>​lsb_release -sc</​code>​))
 Pin-Priority:​ 1001((Cette priorité entraîne l'​installation du paquet même s'il s'agit d'un retour en arrière.)) Pin-Priority:​ 1001((Cette priorité entraîne l'​installation du paquet même s'il s'agit d'un retour en arrière.))
  
 Package: * Package: *
-Pin: release a=nom de votre version d'​Ubuntu-updates((Pour connaître le nom de votre version d'​Ubuntu (trustyxenial ​ou autre), veuillez ouvrir un terminal, et y **copier-coller** cette commande <​code>​lsb_release -sc</​code>​))+Pin: release a=nom de votre version d'​Ubuntu-updates((Pour connaître le nom de votre version d'​Ubuntu (bionicfocal ou autre), veuillez ouvrir un terminal, et y **copier-coller** cette commande <​code>​lsb_release -sc</​code>​))
 Pin-Priority:​ 1001((Cette priorité entraîne l'​installation du paquet même s'il s'agit d'un retour en arrière.)) Pin-Priority:​ 1001((Cette priorité entraîne l'​installation du paquet même s'il s'agit d'un retour en arrière.))
  
 Package: * Package: *
-Pin: release a=nom de votre version d'​Ubuntu-security((Pour connaître le nom de votre version d'​Ubuntu (trustyxenial ​ou autre), veuillez ouvrir un terminal, et y **copier-coller** cette commande <​code>​lsb_release -sc</​code>​))+Pin: release a=nom de votre version d'​Ubuntu-security((Pour connaître le nom de votre version d'​Ubuntu (bionicfocal ou autre), veuillez ouvrir un terminal, et y **copier-coller** cette commande <​code>​lsb_release -sc</​code>​))
 Pin-Priority:​ 1001((Cette priorité entraîne l'​installation du paquet même s'il s'agit d'un retour en arrière.)) Pin-Priority:​ 1001((Cette priorité entraîne l'​installation du paquet même s'il s'agit d'un retour en arrière.))
  
 Package: * Package: *
-Pin: release a=nom de votre version d'​Ubuntu-backports((Pour connaître le nom de votre version d'​Ubuntu (trustyxenial ​ou autre), veuillez ouvrir un terminal, et y **copier-coller** cette commande <​code>​lsb_release -sc</​code>​))+Pin: release a=nom de votre version d'​Ubuntu-backports((Pour connaître le nom de votre version d'​Ubuntu (bionicfocal ou autre), veuillez ouvrir un terminal, et y **copier-coller** cette commande <​code>​lsb_release -sc</​code>​))
 Pin-Priority:​ 1001((Cette priorité entraîne l'​installation du paquet même s'il s'agit d'un retour en arrière.)) Pin-Priority:​ 1001((Cette priorité entraîne l'​installation du paquet même s'il s'agit d'un retour en arrière.))
  
 Package: * Package: *
-Pin: release a=nom de votre version d'​Ubuntu-proposed((Pour connaître le nom de votre version d'​Ubuntu (trustyxenial ​ou autre), veuillez ouvrir un terminal, et y **copier-coller** cette commande <​code>​lsb_release -sc</​code>​))+Pin: release a=nom de votre version d'​Ubuntu-proposed((Pour connaître le nom de votre version d'​Ubuntu (bionicfocal ou autre), veuillez ouvrir un terminal, et y **copier-coller** cette commande <​code>​lsb_release -sc</​code>​))
 Pin-Priority:​ -1((Cette priorité empêche l'​installation de la version.)) Pin-Priority:​ -1((Cette priorité empêche l'​installation de la version.))
  
Ligne 155: Ligne 155:
 sudo apt-get update</​code>​ sudo apt-get update</​code>​
  
-^ Adresses des dépôts | **[[depots_trusty#​depot_commercial|Ubuntu ​14.04 LTS (Trusty)]]** | **[[depots_xenial#​depot_commercial|Ubuntu ​16.04 LTS (Xenial)]]** |+^ Adresses des dépôts | **[[depots_bionic#​depot_commercial|Ubuntu ​18.04 LTS (Bionic)]]** | **[[depots_focal#​depot_commercial|Ubuntu ​20.04 LTS (Focal)]]** |
  
  
Ligne 165: Ligne 165:
 Ces dépôts sont utiles pour les possesseurs d'​ordinateurs ayant un processeur de type [[ppc|PowerPC]],​ tels les Mac G3, G4 et G5, et les machines basées sur les processeurs Cell comme la PlayStation 3. La version PowerPC d'​Ubuntu n'​étant plus développée de manière officielle, des paquets ont été portés vers cette architecture et sont maintenus de manière non officielle dans le dépôt suivant. Ces dépôts sont utiles pour les possesseurs d'​ordinateurs ayant un processeur de type [[ppc|PowerPC]],​ tels les Mac G3, G4 et G5, et les machines basées sur les processeurs Cell comme la PlayStation 3. La version PowerPC d'​Ubuntu n'​étant plus développée de manière officielle, des paquets ont été portés vers cette architecture et sont maintenus de manière non officielle dans le dépôt suivant.
  
-^Adresse des dépôts | **[[:​distributions_ppc|Ubuntu ​16.04 LTS (Xenial)]]**| ​+^Adresse des dépôts | **[[:​distributions_ppc|Ubuntu ​18.04 LTS (Bionic)]]**| ​
  
 ==== Ports pour architecture ARM ==== ==== Ports pour architecture ARM ====
Ligne 175: Ligne 175:
 Cette version est très utilisée dans nos smartphones et dans la plupart des tablettes tactiles du marché. Cette version est très utilisée dans nos smartphones et dans la plupart des tablettes tactiles du marché.
  
-^Adresse des dépôts | **[[depots_trusty#​depot_portage|Ubuntu ​14.04 LTS (Trusty)]]** | **[[depots_xenial#​depot_portage|Ubuntu ​16.04 LTS (Xenial)]]** | +^Adresse des dépôts | **[[depots_bionic#​depot_portage|Ubuntu ​18.04 LTS (Bionic)]]** | **[[depots_focal#​depot_portage|Ubuntu ​20.04 LTS (Focal)]]** | 
  
 ===== Dépôts par version d'​Ubuntu ===== ===== Dépôts par version d'​Ubuntu =====
-  * [[depots_trusty|Ubuntu ​14.04 LTS "​The ​Trusty Thar"]] +  * [[depots_bionic|Ubuntu ​18.04 LTS "​The ​Bionic Beaver"]] 
-  * [[depots_xenial|Ubuntu ​16.04 LTS "​The ​Xenial Xerus"]]+  * [[depots_focal|Ubuntu ​20.04 LTS "​The ​Focal Fossa"]]
  
 Si vous utilisez encore une [[:​old-releases|version Ubuntu qui n'est plus supportée]],​ utilisez http://​old-releases.ubuntu.com/​ubuntu/​dists/​ \\ Si vous utilisez encore une [[:​old-releases|version Ubuntu qui n'est plus supportée]],​ utilisez http://​old-releases.ubuntu.com/​ubuntu/​dists/​ \\
  • depots.txt
  • Dernière modification: Le 12/11/2020, 02:06
  • par andykimpe